Results 1 to 2 of 2
  1. #1
    Active Lancista
    Join Date
    Jun 2013
    Location
    Australia
    Posts
    17
    Downloads
    0
    Uploads
    0

    Flava 2000 injection won't start?

    I have had to shift the Lancia 2000 injection, fixing the shed.
    Not been started for 15 years.
    The fuel pump i replaced today as it was dead when i tested it but no current to the pump.
    I checked the fuses expecting a blown , all good. new fuel.
    Taped the relays near the battery, little fuse box in that area, fuses OK.
    Put some fuel down the manifold and it would just run.
    Then i hot wired the pump wouldn't start. Injectors dry when i removed them.


    *Find the pictures from the manual, please?
    Is it likely that relay 12 + 13 are at fault ?
    Fuel pump solenoid/relay, main solenoid/relay.Click image for larger version. 

Name:	Flavia 2000 eng bay 2.jpg 
Views:	7 
Size:	146.0 KB 
ID:	14944Click image for larger version. 

Name:	Flavia 2000 eng bay.jpg 
Views:	5 
Size:	167.0 KB 
ID:	14945

    No power getting to them, perhaps?


    Any ideas, please?
    Lancia Fulvia Sport S1.
    Lancia 2000.
    Flavia Milleotto.
    Peugeot 206 GTI180.
    Alfa 164,147.

  2. #2
    Active Lancista
    Join Date
    Jun 2013
    Location
    Australia
    Posts
    17
    Downloads
    0
    Uploads
    0

    Re: Flava 2000 injection won't start?

    No pulse at injectors.
    Lancia Fulvia Sport S1.
    Lancia 2000.
    Flavia Milleotto.
    Peugeot 206 GTI180.
    Alfa 164,147.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •