Results 1 to 7 of 7

Thread: Headlights

  1. #1
    Active Lancista
    Join Date
    Jul 2019
    Location
    LEIGH-ON-SEA
    Posts
    23
    Downloads
    21
    Uploads
    0

    Headlights

    I'm slowly going through niggles to sort out, the latest is the headlights.

    Sidelights work fine, but when I move the stalk into the main bean position I get full beam......likely to be a contact problem within the stalk or something else ?

    Has anyone had a similar problem ?

    Cheers

  2. #2
    Legendary Lancista lancialulu's Avatar
    Join Date
    Sep 2007
    Location
    Colchester
    Posts
    2,372
    Downloads
    58
    Uploads
    0

    Re: Headlights

    Move the stalk down for dipped and slightly pull the stalk for main. It is very subtle first time....

    Switch is a bit of a nightmare and wires are know to fall off their soldered joints....

  3. #3
    Active Lancista
    Join Date
    Jul 2019
    Location
    LEIGH-ON-SEA
    Posts
    23
    Downloads
    21
    Uploads
    0

    Re: Headlights

    I will caress it and see if I have the touch.....failing that I'll check out the wiring.

    Cheers.

  4. #4
    Master Lancista NeilS's Avatar
    Join Date
    Jun 2009
    Location
    Surrey
    Posts
    216
    Downloads
    49
    Uploads
    3

    Re: Headlights

    If it a S2 Fulvia and probably the same in a S1, you should hear the relays click in the centre near the fuse box too, possibly the relay have stuck, might be worth checking those connections and the earths on the stalk, are there the locking rings tight to the steering column?

  5. #5
    Active Lancista
    Join Date
    Jul 2019
    Location
    LEIGH-ON-SEA
    Posts
    23
    Downloads
    21
    Uploads
    0

    Re: Headlights

    Thanks will check it when I get back from vacation.......something to look forward too !

  6. #6
    Legendary Lancista fay66's Avatar
    Join Date
    Oct 2007
    Location
    Silsoe Bedfordshire England
    Age
    80
    Posts
    1,636
    Downloads
    93
    Uploads
    86

    Re: Headlights

    Quote Originally Posted by Robin4963 View Post
    Thanks will check it when I get back from vacation.......something to look forward too !
    With series 1, with the knob pulled to the first position you get the dipped beams on, pushing the lever forward as you would to dip the headlights on main beam, will turn the dipped headlights off and just leave you with sidelights, very disconcerting when you're bombing down an unlit road and you find you can't see anything on just sidelights.
    Frightened the life out of me when it happened!
    If after you've pulled it out you then rotate it to the right, all four lights come on and the blue main beam warning light will be alight in the instrument cluster, pushing the dip switch/indicator lever from this position the main beams will go out and the blue light in the cluster will be extinguished.
    Series 2 is a totally different set up.
    I suspect this is possibly your "problem"
    The series 1 light switch takes a bit of getting used to, particularly if you have weak springs on the dips witch part of the switch.
    Have a good holiday.
    Brian

  7. #7
    Active Lancista
    Join Date
    Jul 2019
    Location
    LEIGH-ON-SEA
    Posts
    23
    Downloads
    21
    Uploads
    0

    Re: Headlights

    Back from vacation and need to look at this.

    So (On S2)
    Slide switch sidelights on...good
    Push lever down...assume this should be main beam (?)..........Full beam comes on....not so good.
    Pull lever towards me full beam stays on.

    The relays are clicking so perhaps first port of call is the stalk/column ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •